diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -101,11 +101,11 @@ }; deployChecks = deploy: builtins.mapAttrs (_: check: check deploy) { - schema = deploy: final.runCommand "jsonschema-deploy-system" { } '' + deploy-schema = deploy: final.runCommand "jsonschema-deploy-system" { } '' ${final.python3.pkgs.jsonschema}/bin/jsonschema -i ${final.writeText "deploy.json" (builtins.toJSON deploy)} ${./interface.json} && touch $out ''; - activate = deploy: + deploy-activate = deploy: let profiles = builtins.concatLists (final.lib.mapAttrsToList (nodeName: node: final.lib.mapAttrsToList (profileName: profile: [ (toString profile.path) nodeName profileName ]) node.profiles) deploy.nodes); in |