aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index d87702f..75ea2b7 100644
--- a/flake.nix
+++ b/flake.nix
@@ -90,7 +90,11 @@
# work around https://github.com/NixOS/nixpkgs/issues/73404
cd /tmp
- $PROFILE/bin/switch-to-configuration switch
+ if [[ $DRY_ACTIVATE == "1" ]]; then
+ $PROFILE/bin/switch-to-configuration dry-activate
+ else
+ $PROFILE/bin/switch-to-configuration switch
+ fi
# https://github.com/serokell/deploy-rs/issues/31
${with base.config.boot.loader;