aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorOleg Pykhalov2021-03-31 13:14:10 +0300
committerOleg Pykhalov2021-04-07 19:40:15 +0300
commit46ac71aa245549965a3d9dfdabf6421b39f62289 (patch)
tree20b65e894d8cff0124ec7e22b5dd68d22364e14a /flake.nix
parent9e405fbc5ab5bacbd271fd78c6b6b6877c4d9f8d (diff)
Add dry activate argument.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index d87702f..75ea2b7 100644
--- a/flake.nix
+++ b/flake.nix
@@ -90,7 +90,11 @@
# work around https://github.com/NixOS/nixpkgs/issues/73404
cd /tmp
- $PROFILE/bin/switch-to-configuration switch
+ if [[ $DRY_ACTIVATE == "1" ]]; then
+ $PROFILE/bin/switch-to-configuration dry-activate
+ else
+ $PROFILE/bin/switch-to-configuration switch
+ fi
# https://github.com/serokell/deploy-rs/issues/31
${with base.config.boot.loader;