aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 3 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index 884bbf3..5d9427f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -34,17 +34,9 @@
program = "${self.defaultPackage."${system}"}/bin/deploy";
};
- devShell =
- let
- inherit (self.packages.${system}) deploy-rs;
- in
- pkgs.mkShell {
- inherit (deploy-rs)
- nativeBuildInputs
- builtDependencies;
-
- buildInputs = deploy-rs.buildInputs
- ++ [ pkgs.nixUnstable ];
+ devShell = pkgs.mkShell {
+ inputsFrom = [ self.packages.${system}.deploy-rs ];
+ buildInputs = [ pkgs.nixUnstable ];
};
lib = rec {