aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorChristian Höppner2020-11-16 11:49:00 +0000
committerChristian Höppner2020-11-16 11:49:00 +0000
commit1c84cace61cb2ac6044f3c3da3dd98285bf1f3b4 (patch)
tree857fe8913adb06c70f02914e1e50bf3b4f04e3c4 /flake.nix
parent47df4ff9284051a5c41a7b2b5696f9c4ccbe792f (diff)
fixup! [OPS-1085] Add CI
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 3 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index 884bbf3..5d9427f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -34,17 +34,9 @@
program = "${self.defaultPackage."${system}"}/bin/deploy";
};
- devShell =
- let
- inherit (self.packages.${system}) deploy-rs;
- in
- pkgs.mkShell {
- inherit (deploy-rs)
- nativeBuildInputs
- builtDependencies;
-
- buildInputs = deploy-rs.buildInputs
- ++ [ pkgs.nixUnstable ];
+ devShell = pkgs.mkShell {
+ inputsFrom = [ self.packages.${system}.deploy-rs ];
+ buildInputs = [ pkgs.nixUnstable ];
};
lib = rec {