aboutsummaryrefslogtreecommitdiff
path: root/nix/tests/deploy-flake.nix
diff options
context:
space:
mode:
authorstuebinm2024-05-15 23:04:09 +0200
committerstuebinm2024-06-12 13:38:22 +0200
commitd3b11225fcb129ccb5e07b716b7484a93e68771d (patch)
treece46f44631c22b844377a7ae7fa458b3ec5b866e /nix/tests/deploy-flake.nix
parentd5f4b0fabb0374cc122b9880315a874fda09f08a (diff)
test for non-flake build regressions
this adds a nixos vm test doing a deploy on a nix which does not have flakes enabled, to guard against this breaking as it has done before [1]. The existing test infrastructure is changed slightly to make enabling flakes configurable inside the vm's config. [1] https://github.com/serokell/deploy-rs/pull/272
Diffstat (limited to 'nix/tests/deploy-flake.nix')
-rw-r--r--nix/tests/deploy-flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nix/tests/deploy-flake.nix b/nix/tests/deploy-flake.nix
index 3e1e426..47f0f5b 100644
--- a/nix/tests/deploy-flake.nix
+++ b/nix/tests/deploy-flake.nix
@@ -15,7 +15,7 @@
in {
nixosConfigurations.server = nixpkgs.lib.nixosSystem {
inherit system pkgs;
- specialArgs = { inherit inputs; };
+ specialArgs = { inherit inputs; flakes = import inputs.enable-flakes; };
modules = [
./server.nix
./common.nix