aboutsummaryrefslogtreecommitdiff
path: root/nix/tests/common.nix
diff options
context:
space:
mode:
authorstuebinm2024-05-15 23:04:09 +0200
committerstuebinm2024-06-12 13:38:22 +0200
commitd3b11225fcb129ccb5e07b716b7484a93e68771d (patch)
treece46f44631c22b844377a7ae7fa458b3ec5b866e /nix/tests/common.nix
parentd5f4b0fabb0374cc122b9880315a874fda09f08a (diff)
test for non-flake build regressions
this adds a nixos vm test doing a deploy on a nix which does not have flakes enabled, to guard against this breaking as it has done before [1]. The existing test infrastructure is changed slightly to make enabling flakes configurable inside the vm's config. [1] https://github.com/serokell/deploy-rs/pull/272
Diffstat (limited to 'nix/tests/common.nix')
-rw-r--r--nix/tests/common.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nix/tests/common.nix b/nix/tests/common.nix
index 37abb5d..9e5f363 100644
--- a/nix/tests/common.nix
+++ b/nix/tests/common.nix
@@ -2,11 +2,12 @@
#
# SPDX-License-Identifier: MPL-2.0
-{inputs, pkgs, ...}: {
+{inputs, pkgs, flakes, ...}: {
nix = {
registry.nixpkgs.flake = inputs.nixpkgs;
+ nixPath = [ "nixpkgs=${inputs.nixpkgs}" ];
extraOptions = ''
- experimental-features = nix-command flakes
+ experimental-features = ${if flakes then "nix-command flakes" else "nix-command"}
'';
settings = {
trusted-users = [ "root" "@wheel" ];