diff options
author | Alexander Bantyev | 2021-09-28 12:48:27 +0300 |
---|---|---|
committer | Alexander Bantyev | 2021-09-28 12:51:24 +0300 |
commit | 9a02de4373e0ec272d08a417b269a28ac8b961b4 (patch) | |
tree | 14ab9c40a435a54c151fe1f9640419e11b419a85 /flake.nix | |
parent | ea5f2ab58145b2c143f27cbcd64cc2ba4300950c (diff) |
Fix darwin build
Frameworks are libraries used at runtime, so should be in buildInputs
and not nativeBuildInputs.
Closes https://github.com/serokell/deploy-rs/issues/132
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -20,10 +20,10 @@ overlay = final: prev: let system = final.system; - isDarwin = final.lib.strings.hasSuffix "-darwin" system; - darwinOptions = final.lib.optionalAttrs isDarwin { - nativeBuildInputs = [ - final.darwin.apple_sdk.frameworks.SystemConfiguration + darwinOptions = final.lib.optionalAttrs final.stdenv.isDarwin { + buildInputs = with final.darwin.apple_sdk.frameworks; [ + SystemConfiguration + CoreServices ]; }; in |