aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlexander Bantyev2021-05-18 17:36:09 +0300
committerAlexander Bantyev2021-05-18 22:11:35 +0300
commit86fecf7db28911315f9f96070de8e689a0e69791 (patch)
treeefd1c164288e40a6d50201be16956e52c17c20d2 /flake.nix
parent8dd6e23b95141b739b6e8ffa07d2141974ebe3b9 (diff)
Fix rollback to old profiles
In 5d5da48 (https://github.com/serokell/deploy-rs/pull/81), $DRY_ACTIVATE is used in a bash script with -u. When DRY_ACTIVATE is not set (which it is not for older profiles), the script fails. Fix this by setting a fallback.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index bc1ebc6..c6b3357 100644
--- a/flake.nix
+++ b/flake.nix
@@ -73,7 +73,7 @@
#!${pkgs.runtimeShell}
set -euo pipefail
- if [[ $DRY_ACTIVATE == "1" ]]
+ if [[ "x''${DRY_ACTIVATE:-}" == "x1" ]]
then
${if builtins.hasAttr "dryActivate" customSelf
then