aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlexander Bantyev2022-12-29 18:25:47 +0400
committerGitHub2022-12-29 18:25:47 +0400
commit3878dd40f622d327ee912e9b4077909834261772 (patch)
treef03a91ee3d24ebfb149baa9c7eb052a97f01b99f /flake.nix
parent2a3c5f70eee04a465aa534d8bd4fcc9bb3c4a8ce (diff)
parent068372aad18f04122bbdb836e36c655c157ebe71 (diff)
Merge pull request #176 from Ma27/activate-boot
Add new activation strategy `boot` as equivalent to `nixos-rebuild boot`
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix31
1 files changed, 20 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index ecb1331..9b8e6eb 100644
--- a/flake.nix
+++ b/flake.nix
@@ -63,6 +63,9 @@
if [[ "''${DRY_ACTIVATE:-}" == "1" ]]
then
${customSelf.dryActivate or "echo ${final.writeScript "activate" activate}"}
+ elif [[ "''${BOOT:-}" == "1" ]]
+ then
+ ${customSelf.boot or "echo ${final.writeScript "activate" activate}"}
else
${activate}
fi
@@ -83,17 +86,23 @@
};
};
- nixos = base: (custom // { dryActivate = "$PROFILE/bin/switch-to-configuration dry-activate"; }) base.config.system.build.toplevel ''
- # work around https://github.com/NixOS/nixpkgs/issues/73404
- cd /tmp
-
- $PROFILE/bin/switch-to-configuration switch
-
- # https://github.com/serokell/deploy-rs/issues/31
- ${with base.config.boot.loader;
- final.lib.optionalString systemd-boot.enable
- "sed -i '/^default /d' ${efi.efiSysMountPoint}/loader/loader.conf"}
- '';
+ nixos = base:
+ (custom // {
+ dryActivate = "$PROFILE/bin/switch-to-configuration dry-activate";
+ boot = "$PROFILE/bin/switch-to-configuration boot";
+ })
+ base.config.system.build.toplevel
+ ''
+ # work around https://github.com/NixOS/nixpkgs/issues/73404
+ cd /tmp
+
+ $PROFILE/bin/switch-to-configuration switch
+
+ # https://github.com/serokell/deploy-rs/issues/31
+ ${with base.config.boot.loader;
+ final.lib.optionalString systemd-boot.enable
+ "sed -i '/^default /d' ${efi.efiSysMountPoint}/loader/loader.conf"}
+ '';
home-manager = base: custom base.activationPackage "$PROFILE/activate";