aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorFlakebi2023-04-16 15:27:22 +0200
committerFlakebi2023-04-16 16:38:12 +0200
commit03b02d2097c1e7eb142e086bdc1fa20252246c03 (patch)
treeb2b5b50f867ddb77b16d8ecd7887a0e961bdfeb4 /flake.nix
parent8c9ea9605eed20528bf60fae35a2b613b901fd77 (diff)
Make it possible to not rebuild deploy-rs
Use the deploy-rs from the final packages set. This can avoid rebuilding deploy-rs when using it in a nixos config. It can use the version cached in nixpkgs. Also add instructions to the readme on how to craft an overlay that uses nixpkgs deploy-rs.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 9b8e6eb..9e8bb4e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -77,7 +77,7 @@
name = base.name + "-activate-rs";
text = ''
#!${final.runtimeShell}
- exec ${self.packages.${system}.default}/bin/activate "$@"
+ exec ${final.deploy-rs.deploy-rs}/bin/activate "$@"
'';
executable = true;
destination = "/activate-rs";