aboutsummaryrefslogtreecommitdiff
path: root/examples/system/hello.nix
diff options
context:
space:
mode:
authornotgne22020-09-29 15:10:06 -0700
committernotgne22020-09-29 15:10:06 -0700
commit8d21dd335e5259dadf832a5d1a7c72b9dd1f4400 (patch)
treebc73e231777d5e0f7f2efa8e9a760a34e95950d1 /examples/system/hello.nix
parente3c55575ca6bfd0c9166c52b4aac76b3761bb313 (diff)
Add license information, reformat Nix files, clean up
Diffstat (limited to 'examples/system/hello.nix')
-rw-r--r--examples/system/hello.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/examples/system/hello.nix b/examples/system/hello.nix
index 8c207f1..df57308 100644
--- a/examples/system/hello.nix
+++ b/examples/system/hello.nix
@@ -1,3 +1,7 @@
+# SPDX-FileCopyrightText: 2020 Serokell <https://serokell.io/>
+#
+# SPDX-License-Identifier: MPL-2.0
+
nixpkgs:
let
pkgs = nixpkgs.legacyPackages.x86_64-linux;
@@ -14,11 +18,10 @@ let
text = mkService "hello" {
unitConfig.WantedBy = [ "multi-user.target" ];
path = [ pkgs.hello ];
- script = "hello -g lel; touch $HOME/oof";
+ script = "hello";
};
};
-in
-pkgs.writeShellScriptBin "activate" ''
+in pkgs.writeShellScriptBin "activate" ''
mkdir -p $HOME/.config/systemd/user
rm $HOME/.config/systemd/user/hello.service
ln -s ${service} $HOME/.config/systemd/user/hello.service