aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authornotgne22020-10-08 20:01:01 -0700
committernotgne22020-10-08 20:01:01 -0700
commit219d55e99e792a093c12dbc045bed88a4bfe1916 (patch)
tree79b0552cc3d85ac0a97fb6649bcfab1f18520142 /default.nix
parent518f7f5b4f1db83cab61941ab8887b0df76ce8d8 (diff)
Minor flake and documentation fixes
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..873ece4
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,13 @@
+(import
+ (
+ let
+ lock = builtins.fromJSON (builtins.readFile ./flake.lock);
+ in
+ fetchTarball {
+ url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
+ sha256 = lock.nodes.flake-compat.locked.narHash;
+ }
+ )
+ {
+ src = ./.;
+ }).defaultNix