diff options
author | Roman Melnikov | 2023-09-06 14:54:22 +0200 |
---|---|---|
committer | Roman Melnikov | 2023-09-12 12:00:17 +0200 |
commit | f26e888c41d28107de9dbc5b4e1553c1dfcf83db (patch) | |
tree | e3a76bfd3b13bcd2888cabfc7cd6cada32129139 /Cargo.toml | |
parent | 724463b5a94daa810abfc64a4f87faef4e00f984 (diff) |
[#201] Deduce profile directory during activation
Problem: Since https://github.com/NixOS/nix/pull/5226 nix profiles for
users are stored in 'XDG_STATE_HOME' or 'HOME' directory. However,
'deploy-rs' still expects profiles to be present in
'/nix/var/nix/profiles/per-user'. As a result, an attempt to deploy a
profile with newer nix may fail with an error about non-existing files.
Solution: Instead of deducing the profile path prior to ssh'ing and
actual activation, deduce the path to the profile during as a part of
'activate-rs' invocation.
Now if the profile path is not specified explicitly as an attribute in
profile within the deploy flake, the path to the profile is determined
based on the user to which the profile belongs and on the values of
'XDG_STATE_HOME' and 'HOME' variables.
Additionally, if the old profile directory (in
'/nix/var/nix/profiles/per-user') for a given user already exists, it is
used instead for the sake of backward compatibility.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -12,6 +12,7 @@ edition = "2018" [dependencies] clap = { version = "3.0.0-beta.2", features = [ "wrap_help" ] } +dirs = "5.0.1" flexi_logger = "0.16" fork = "0.1" futures-util = "0.3.6" |