diff options
author | Roman Melnikov | 2023-04-19 17:46:43 +0800 |
---|---|---|
committer | Roman Melnikov | 2023-04-20 15:13:13 +0800 |
commit | 784e9ee24d977c99dcb5ba5aef81dae48cb899fb (patch) | |
tree | 141acdf6bd62aae808f4c9542819ebc211f09ac2 /Cargo.toml | |
parent | 8c9ea9605eed20528bf60fae35a2b613b901fd77 (diff) |
[Chore] Handle 'temp_path' as an actual 'Path' instead of 'String'
Problem: 'temp_path' and 'lock_path' are handled as 'String'.
This can be a problem when the 'temp_path' directory is a symlink
on the target system, e.g. this is the case with the default
'/tmp' and macOS, where this directory is actually a symlink to '/private/tmp'.
Solution: Handle 'temp_path' and 'lock_path' as actual Paths.
Also, canonicalize 'temp_path' to avoid canary file path mismatches when checking
filesystem events.
As a side effect, also update the 'notify' dependency to the latest stable version.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -17,7 +17,7 @@ fork = "0.1" futures-util = "0.3.6" log = "0.4" merge = "0.1.0" -notify = "5.0.0-pre.3" +notify = "5.1.0" rnix = "0.8" serde = { version = "1.0.104", features = [ "derive" ] } serde_json = "1.0.48" |