summaryrefslogtreecommitdiff
path: root/npins/default.nix
diff options
context:
space:
mode:
authorRaito Bezarius2024-04-18 14:34:36 +0200
committerRaito Bezarius2024-04-18 14:34:36 +0200
commit5289b86a5c14ec99311424022a867872173edce4 (patch)
tree75da592377a833b2ce7e160019aa34e4ae5b6ffb /npins/default.nix
parentfb9a1e93c2163b170979523f9a0cae90b472a16c (diff)
chore: nixify the project
So that I stop doing `nix run` one-offs! Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
Diffstat (limited to 'npins/default.nix')
-rw-r--r--npins/default.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/npins/default.nix b/npins/default.nix
new file mode 100644
index 0000000..4a7c372
--- /dev/null
+++ b/npins/default.nix
@@ -0,0 +1,47 @@
+# Generated by npins. Do not modify; will be overwritten regularly
+let
+ data = builtins.fromJSON (builtins.readFile ./sources.json);
+ version = data.version;
+
+ mkSource = spec:
+ assert spec ? type; let
+ path =
+ if spec.type == "Git" then mkGitSource spec
+ else if spec.type == "GitRelease" then mkGitSource spec
+ else if spec.type == "PyPi" then mkPyPiSource spec
+ else if spec.type == "Channel" then mkChannelSource spec
+ else builtins.throw "Unknown source type ${spec.type}";
+ in
+ spec // { outPath = path; };
+
+ mkGitSource = { repository, revision, url ? null, hash, ... }:
+ assert repository ? type;
+ # At the moment, either it is a plain git repository (which has an url), or it is a GitHub/GitLab repository
+ # In the latter case, there we will always be an url to the tarball
+ if url != null then
+ (builtins.fetchTarball {
+ inherit url;
+ sha256 = hash; # FIXME: check nix version & use SRI hashes
+ })
+ else assert repository.type == "Git"; builtins.fetchGit {
+ url = repository.url;
+ rev = revision;
+ # hash = hash;
+ };
+
+ mkPyPiSource = { url, hash, ... }:
+ builtins.fetchurl {
+ inherit url;
+ sha256 = hash;
+ };
+
+ mkChannelSource = { url, hash, ... }:
+ builtins.fetchTarball {
+ inherit url;
+ sha256 = hash;
+ };
+in
+if version == 3 then
+ builtins.mapAttrs (_: mkSource) data.pins
+else
+ throw "Unsupported format version ${toString version} in sources.json. Try running `npins upgrade`"