aboutsummaryrefslogtreecommitdiff
path: root/test.nix
diff options
context:
space:
mode:
Diffstat (limited to 'test.nix')
-rw-r--r--test.nix21
1 files changed, 7 insertions, 14 deletions
diff --git a/test.nix b/test.nix
index 3df16d6..c4d2f56 100644
--- a/test.nix
+++ b/test.nix
@@ -1,16 +1,9 @@
-# NOTE: this file is only meant to be used for quickly building a
-# version of workadventure, not for actual use. Use callPackages on
-# the subdirectories directly for use e.g. in modules.
-with import <nixpkgs> {};
+{ system ? builtins.currentSystem, nixpkgs ? <nixpkgs> }:
-lib.fix (self: let
- callPackage = lib.callPackageWith self;
-in pkgs // {
- workadventure-back = callPackage ./back {};
- workadventure-pusher = callPackage ./pusher {};
- workadventure-messages = callPackage ./messages {};
- workadventure-front = callPackage ./front {};
- workadventure-uploader = callPackage ./uploader {};
- workadventure-maps = callPackage ./maps {};
-})
+let
+ pkgs = import nixpkgs { inherit system; overlays = [ (import ./overlay.nix) ]; };
+in {
+ inherit pkgs;
+ inherit (pkgs) workadventure;
+}