aboutsummaryrefslogtreecommitdiff
path: root/test.nix
diff options
context:
space:
mode:
Diffstat (limited to 'test.nix')
-rw-r--r--test.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/test.nix b/test.nix
new file mode 100644
index 0000000..3df16d6
--- /dev/null
+++ b/test.nix
@@ -0,0 +1,16 @@
+# NOTE: this file is only meant to be used for quickly building a
+# version of workadventure, not for actual use. Use callPackages on
+# the subdirectories directly for use e.g. in modules.
+
+with import <nixpkgs> {};
+
+lib.fix (self: let
+ callPackage = lib.callPackageWith self;
+in pkgs // {
+ workadventure-back = callPackage ./back {};
+ workadventure-pusher = callPackage ./pusher {};
+ workadventure-messages = callPackage ./messages {};
+ workadventure-front = callPackage ./front {};
+ workadventure-uploader = callPackage ./uploader {};
+ workadventure-maps = callPackage ./maps {};
+})