aboutsummaryrefslogtreecommitdiff
path: root/pusher/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pusher/default.nix')
-rw-r--r--pusher/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pusher/default.nix b/pusher/default.nix
index cb6ee0d..64d0fdb 100644
--- a/pusher/default.nix
+++ b/pusher/default.nix
@@ -1,4 +1,4 @@
-workadventuresrc:
+workadventuresrc: waname:
{ stdenv
, autoPatchelfHook
@@ -34,8 +34,9 @@ let
in
yarn2nix-moretea.mkYarnPackage rec {
- pname = "workadventurepusher";
+ pname = "workadventurepusher-${waname}";
version = "unstable";
+ name = pname + "-" + version;
src = "${workadventuresrc}/pusher";
@@ -68,7 +69,7 @@ yarn2nix-moretea.mkYarnPackage rec {
# node-abi needs to the abi of the node here
# getconf is required for detect-libc (used by node-pre-gyp) to properly
# detect current libc
- makeWrapper '${nodejs-14_x}/bin/node' "$out/bin/${pname}" \
+ makeWrapper '${nodejs-14_x}/bin/node' "$out/bin/workadventurepusher" \
--set NODE_PATH $out/libexec/workadventureback/node_modules \
--prefix PATH : ${lib.makeBinPath [ getconf ]} \
--add-flags "$out/dist/server.js"