aboutsummaryrefslogtreecommitdiff
path: root/instance-options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'instance-options.nix')
-rw-r--r--instance-options.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/instance-options.nix b/instance-options.nix
index 58cc99e..50d7bdc 100644
--- a/instance-options.nix
+++ b/instance-options.nix
@@ -3,8 +3,7 @@
{ lib, pkgs, config, ... }:
with lib;
-let workadventure = import ./workadventure-nix.nix { inherit lib pkgs; };
-in
+with pkgs;
{
options = rec {
backend = {
@@ -85,7 +84,7 @@ in
};
admin = mkOption {
- default = "/admin";
+ default = "/pusher/admin";
type = types.str;
description = "The base url for the admin, from the browser's point of view";
};
@@ -115,8 +114,8 @@ in
};
domain = mkOption {
- default = null;
- type = types.nullOr types.str;
+ default = "localhost";
+ type = types.str;
description = "The domain name to serve workadenture services under. Mutually exclusive with domains.X";
};