aboutsummaryrefslogtreecommitdiff
path: root/instance-options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'instance-options.nix')
-rw-r--r--instance-options.nix34
1 files changed, 9 insertions, 25 deletions
diff --git a/instance-options.nix b/instance-options.nix
index 6c3d6f2..c01932e 100644
--- a/instance-options.nix
+++ b/instance-options.nix
@@ -6,7 +6,13 @@ with lib;
with pkgs;
{
options = rec {
-
+
+ packageset = mkOption {
+ default = workadventure-tcm;
+ type = types.attrs;
+ description = "The package set to use. It should contain a front, backend, pusher, and maps package.";
+ };
+
backend = {
enable = mkOption {
default = true;
@@ -24,13 +30,6 @@ with pkgs;
type = types.ints.u16;
description = "The TCP port the backend will bind to for grpc";
};
-
- package = mkOption {
- default = workadventure-tcm.back;
- defaultText = "third_party.workadventure-nix.back";
- type = types.package;
- description = "Backend package to use";
- };
};
pusher = {
@@ -44,23 +43,9 @@ with pkgs;
type = types.ints.u16;
description = "The TCP port the pusher will bind to";
};
-
- package = mkOption {
- default = workadventure-tcm.pusher;
- defaultText = "third_party.workadventure-nix.pusher";
- type = types.package;
- description = "Pusher package to use";
- };
};
frontend = {
- package = mkOption {
- default = workadventure-tcm.front;
- defaultText = "third_party.workadventure-nix.front";
- type = types.package;
- description = "Front package to use";
- };
-
debugMode = mkOption {
default = false;
description = "Whether or not to run the frontend in debug mode";
@@ -238,9 +223,8 @@ with pkgs;
};
path = mkOption {
default = workadventure-tcm.maps.outPath + "/workadventuremaps/";
- defaultText = "third_party.workadventure-nix.maps";
- type = types.path;
- description = "Maps package to use";
+ type = types.nullOr types.path;
+ description = "Path to a directory which should be served under /maps. If maps are enabled and this path set to null, the default maps provided in the packageset are used instead.";
};
};
};