aboutsummaryrefslogtreecommitdiff
path: root/instance-options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'instance-options.nix')
-rw-r--r--instance-options.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/instance-options.nix b/instance-options.nix
index c01932e..8df507d 100644
--- a/instance-options.nix
+++ b/instance-options.nix
@@ -167,7 +167,12 @@ with pkgs;
};
password = mkOption {
default = "workadventure";
- description = "Password for TURN authentication";
+ description = "Password for TURN authentication (will be served to clients!)";
+ type = types.str;
+ };
+ staticSecret = mkOption {
+ default = "";
+ description = "Static Secret for the coturn rest API (not served to clients)";
type = types.str;
};
};