aboutsummaryrefslogtreecommitdiff
path: root/front/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'front/default.nix')
-rw-r--r--front/default.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/front/default.nix b/front/default.nix
index 83ccdf4..e881459 100644
--- a/front/default.nix
+++ b/front/default.nix
@@ -1,3 +1,12 @@
+# this file is a function, which returns functions, which in turn
+# return derivations for various versions of workadventure, because
+# apparently nix just works that way.
+#
+# Note that this is meant to be compatible with as many of the existing
+# workadventure forks as possible — so some parts of this may seem outdated
+# or be entirely useless with the "official" version, but are kept in
+# case other forks still need them.
+
workadventuresrc: waname:
{ stdenv
@@ -32,7 +41,9 @@ yarn2nix-moretea.mkYarnPackage
dontStrip = true;
patchPhase = ''
- # remove google tag manager
+ # copy input to actual input location (see the ./templater.sh file in newer wa versions)
+ cp dist/index.tmpl.html dist/index.tmpl.html.tmp
+ # remove google tag manager (for older versions)
replace-literal -efsw '<script async src="https://www.googletagmanager.com/gtag/js?id=UA-10196481-11"></script>' ' ';
# remove quill js cdn
replace-literal -efsr -x .ts 'fileref.setAttribute("href", "https://cdn.quilljs.com/1.3.7/quill.snow.css");' ' ';