aboutsummaryrefslogtreecommitdiff
path: root/back/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'back/default.nix')
-rw-r--r--back/default.nix18
1 files changed, 13 insertions, 5 deletions
diff --git a/back/default.nix b/back/default.nix
index e634467..5a5a973 100644
--- a/back/default.nix
+++ b/back/default.nix
@@ -1,18 +1,26 @@
-with (import <nixpkgs> { }); let
- workadventure-messages = import ../messages;
+{ stdenv
+, autoPatchelfHook
+, fetchFromGitHub
+, fetchzip
+, makeWrapper
+, nodejs-14_x
+, workadventure-messages
+, yarn2nix-moretea
+, ... }:
+let
node-abi = "83";
- node-grpc-precompiled = pkgs.fetchzip {
+ node-grpc-precompiled = fetchzip {
name = "node-grpc-precompiled-node-${node-abi}";
url = "https://node-precompiled-binaries.grpc.io/grpc/v1.24.4/node-v${node-abi}-linux-x64-glibc.tar.gz";
sha256 = "119rhhk1jpi2vwyim7byq3agacasc4q25c26wyzfmy8vk2ih6ndj";
};
- node-grpc-patched = pkgs.stdenv.mkDerivation {
+ node-grpc-patched = stdenv.mkDerivation {
name = "node-grpc";
buildInputs = [ stdenv.cc.cc ];
- nativeBuildInputs = [ pkgs.autoPatchelfHook ];
+ nativeBuildInputs = [ autoPatchelfHook ];
dontUnpack = true;
# spams console
dontStrip = true;