aboutsummaryrefslogtreecommitdiff
path: root/back/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'back/default.nix')
-rw-r--r--back/default.nix73
1 files changed, 41 insertions, 32 deletions
diff --git a/back/default.nix b/back/default.nix
index 6ef0cb9..fada34c 100644
--- a/back/default.nix
+++ b/back/default.nix
@@ -1,34 +1,40 @@
-with (import <nixpkgs> {}); let
-
-node-grpc-precompiled = pkgs.fetchzip {
- name = "node-grpc-precompiled";
- url = "https://node-precompiled-binaries.grpc.io/grpc/v1.24.4/node-v72-linux-x64-glibc.tar.gz";
- sha256 = "11jknppmmp1lpdid9p3lfw2dfsydri3jn1q55zikank3dfd4lhs0";
-};
-
-node-grpc-patched = pkgs.stdenv.mkDerivation {
- name = "node-grpc";
- buildInputs = [ stdenv.cc.cc ];
- nativeBuildInputs = [ pkgs.autoPatchelfHook ];
- dontUnpack = true;
- installPhase = ''
- install -D -m755 ${node-grpc-precompiled}/grpc_node.node $out/bin/grpc_node.node
- '';
-};
+with (import <nixpkgs> { }); let
+
+ workadventure-messages = import ../messages;
+
+ node-abi = "83";
+
+ node-grpc-precompiled = pkgs.fetchzip {
+ name = "node-grpc-precompiled-node-${node-abi}";
+ url = "https://node-precompiled-binaries.grpc.io/grpc/v1.24.4/node-v${node-abi}-linux-x64-glibc.tar.gz";
+ sha256 = "119rhhk1jpi2vwyim7byq3agacasc4q25c26wyzfmy8vk2ih6ndj";
+ };
+
+ node-grpc-patched = pkgs.stdenv.mkDerivation {
+ name = "node-grpc";
+ buildInputs = [ stdenv.cc.cc ];
+ nativeBuildInputs = [ pkgs.autoPatchelfHook ];
+ dontUnpack = true;
+ # spams console
+ dontStrip = true;
+ installPhase = ''
+ install -D -m755 ${node-grpc-precompiled}/grpc_node.node $out/bin/grpc_node.node
+ '';
+ };
-in yarn2nix-moretea.mkYarnPackage rec {
+in
+yarn2nix-moretea.mkYarnPackage rec {
pname = "workadventureback";
version = "unstable";
- src = fetchFromGitHub {
- owner = "thecodingmachine";
- repo = "workadventure";
- rev = "284846e8a59ec0d921189ac3a46e0eb5d1e14818";
- sha256 = "1f1vi226kas7x9y8zw810q5vg1ikn4bb6ha9vnzvqk9y7jlc1n8q";
- } + "/back";
+ src = fetchFromGitHub
+ {
+ owner = "thecodingmachine";
+ repo = "workadventure";
+ rev = "284846e8a59ec0d921189ac3a46e0eb5d1e14818";
+ sha256 = "1f1vi226kas7x9y8zw810q5vg1ikn4bb6ha9vnzvqk9y7jlc1n8q";
+ } + "/back";
- # packageJSON = src + "/back/package.json";
- # yarnLock = src + "/back/yarn.lock";
# NOTE: this is optional and generated dynamically if omitted
yarnNix = ./yarn.nix;
@@ -37,20 +43,23 @@ in yarn2nix-moretea.mkYarnPackage rec {
pkgConfig = {
grpc = {
postInstall = ''
- install -D -m755 ${node-grpc-patched}/bin/grpc_node.node src/node/extension_binary/node-v72-linux-x64-glibc/grpc_node.node
- '';
+ install -D -m755 ${node-grpc-patched}/bin/grpc_node.node src/node/extension_binary/node-v${node-abi}-linux-x64-glibc/grpc_node.node
+ '';
};
};
+ dontStrip = true;
+
buildPhase = ''
mkdir -p $out
- pwd
- HOME=$TMPDIR yarn --offline tsc
- cp -r deps/workadventureback/dist $out/dist
+ ln -s ${workadventure-messages.outPath}/generated deps/${pname}/src/Messages/generated
+ HOME=$TMPDIR yarn --offline run tsc
+ cp -r deps/${pname}/dist $out/dist
'';
postInstall = ''
- makeWrapper '${nodejs}/bin/node' "$out/bin/${pname}" \
+ # node-abi needs to the abi of the node here
+ makeWrapper '${nodejs-14_x}/bin/node' "$out/bin/${pname}" \
--set NODE_PATH $out/libexec/${pname}/node_modules \
--add-flags "$out/dist/server.js"
'';