aboutsummaryrefslogtreecommitdiff
path: root/workadventure.nix
diff options
context:
space:
mode:
authorstuebinm2021-02-26 22:17:59 +0100
committerstuebinm2021-02-26 22:17:59 +0100
commitb0d082051d769a1de60999807be75d5067f06e40 (patch)
tree6bfdee6184a579bd27bd573beba9d09f68994581 /workadventure.nix
parent7352984a5c3bc35f20184ddff97daea93f6b3738 (diff)
remove overlay
(it refused to evaluate on another server for an unknown reason, and instead led to infinite recursion)
Diffstat (limited to 'workadventure.nix')
-rw-r--r--workadventure.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/workadventure.nix b/workadventure.nix
index 49227aa..3ec06b9 100644
--- a/workadventure.nix
+++ b/workadventure.nix
@@ -146,7 +146,8 @@ in
options = {
services.workadventure = mkOption {
type = types.attrsOf (types.submodule (import ./instance-options.nix {
- inherit config lib pkgs;
+ inherit config lib;
+ pkgs = import ./overlay.nix {inherit pkgs lib;};
}));
default = {};
description = "Declarative WorkAdventure instance config";
@@ -159,6 +160,5 @@ in
inherit virtualHosts;
enable = mkDefault true;
};
- nixpkgs.overlays = [ (import ./overlay.nix) ];
};
}