diff options
author | stuebinm | 2021-03-01 23:03:38 +0100 |
---|---|---|
committer | stuebinm | 2021-03-01 23:03:38 +0100 |
commit | ead8c570b6dfd00531bf7ada77e08bbd9955b731 (patch) | |
tree | 7a52e2a55277d4460da82b55a7e21f066d0dae7d /test.nix | |
parent | 61bf48c71c8ae87c55ad7244ce202b6c9cf9c86c (diff) |
fixed test.nix
Previously, it still assumed that there was an ./overlay.nix.
Since overlays in general appear to be slightly broken and generate
an unwieldy amount of infinite recursion, this is no longer the case
and test.nix uses a (slightly uglier) method for testing instead.
Diffstat (limited to 'test.nix')
-rw-r--r-- | test.nix | 11 |
1 files changed, 4 insertions, 7 deletions
@@ -1,9 +1,6 @@ -{ system ? builtins.currentSystem, nixpkgs ? <nixpkgs> }: - let - pkgs = import nixpkgs { inherit system; overlays = [ (import ./overlay.nix) ]; }; -in { - inherit pkgs; - inherit (pkgs) workadventure; -} + pkgs = import <nixpkgs> {}; + wapkgs = import ./wapkgs.nix {inherit pkgs; lib = pkgs.lib; }; +in + wapkgs.workadventure |