aboutsummaryrefslogtreecommitdiff
path: root/instance-options.nix
diff options
context:
space:
mode:
authorstuebinm2021-08-23 15:18:17 +0200
committerstuebinm2021-08-23 15:20:01 +0200
commit4ad2010194037ad25c54631995e89b9d9ee878b3 (patch)
tree80e5a9765a4af3a2f76b210349d1012314f4f05d /instance-options.nix
parent8db4bbc5eccaac218c68fb0853f1972dadd7a40c (diff)
init exneuland as alternative backendexneuland
It appears to work (somewhat). Limitations: - exneuland is not configurable; can only have it once - frontend untested since last update broke things
Diffstat (limited to '')
-rw-r--r--instance-options.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/instance-options.nix b/instance-options.nix
index 17e398d..f2c5ce9 100644
--- a/instance-options.nix
+++ b/instance-options.nix
@@ -13,6 +13,17 @@ with pkgs;
description = "The package set to use. It should contain a front, backend, pusher, and maps package.";
};
+ exneuland = {
+ enable = mkOption {
+ default = true;
+ type = types.bool;
+ };
+ package = mkOption {
+ default = import ./exneuland.nix {};
+ type = types.package;
+ };
+ };
+
backend = {
enable = mkOption {
default = true;