aboutsummaryrefslogtreecommitdiff
path: root/exneuland.nix
diff options
context:
space:
mode:
authorstuebinm2021-08-23 15:18:17 +0200
committerstuebinm2021-08-23 15:20:01 +0200
commit4ad2010194037ad25c54631995e89b9d9ee878b3 (patch)
tree80e5a9765a4af3a2f76b210349d1012314f4f05d /exneuland.nix
parent8db4bbc5eccaac218c68fb0853f1972dadd7a40c (diff)
init exneuland as alternative backendexneuland
It appears to work (somewhat). Limitations: - exneuland is not configurable; can only have it once - frontend untested since last update broke things
Diffstat (limited to '')
-rw-r--r--exneuland.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/exneuland.nix b/exneuland.nix
new file mode 100644
index 0000000..1e9b2b1
--- /dev/null
+++ b/exneuland.nix
@@ -0,0 +1,23 @@
+{ pkgs ? import (import ./nix/sources.nix {}).nixpkgs {}
+, unstable-pkgs ? import (import ./nix/sources.nix {}).nixpkgs-unstable {}
+, exneuland-src ? (import ./nix/sources.nix {}).exneuland
+, ...}:
+
+let
+ packages = pkgs.beam.packagesWith pkgs.beam.interpreters.erlang;
+
+in (packages.mixRelease.override {elixir = unstable-pkgs.elixir_1_12; }) rec {
+ pname = "exneuland";
+ version = "0.0.1";
+ src = exneuland-src;
+
+ mixEnv = "prod";
+
+ mixDeps = packages.fetchMixDeps {
+ pname = "mix-deps-${pname}";
+ inherit src mixEnv version;
+ sha256 = "0nyips2ky6rmgq3xdhrhg4fnw4m2pmck6p1amw9m7qisdqlxhv25";
+ };
+
+ buildInputs = with pkgs; [ rebar3 protobuf ];
+}