aboutsummaryrefslogtreecommitdiff
path: root/example.nix
diff options
context:
space:
mode:
authorstuebinm2021-09-06 15:32:19 +0200
committerstuebinm2021-09-06 15:32:19 +0200
commit6eb992efdd68d80bc62bc7fc0562d8a2e6558096 (patch)
treebf72bcee338521b426bab20e82e15b00c48cf296 /example.nix
parent3afd5c2eac6e8e271457d7bf014521bd7e072411 (diff)
add nix build system and NixOS module
Diffstat (limited to '')
-rw-r--r--example.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/example.nix b/example.nix
new file mode 100644
index 0000000..249ae4a
--- /dev/null
+++ b/example.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+{
+ imports = [ ./module.nix ];
+
+ services.uplcg = {
+ enable = true;
+ port = 8080;
+ domain = "0.0.0.0";
+ # cards = {
+ # generic = {
+ # enabled = true;
+ # black = [
+ # "_ and white _"
+ # ];
+ # white = [
+ # "blue"
+ # "green"
+ # ];
+ # };
+ # };
+ };
+
+ networking.firewall.allowedTCPPorts = [ 8080 ];
+}