aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorstuebinm2024-05-20 19:51:34 +0200
committerstuebinm2024-05-20 19:51:34 +0200
commitae2fdbf72745ac46116c70f8435dacd7c227225f (patch)
treef0a7056b039b35ced716156d2cd6f04798a7bde4 /default.nix
parent82355e81aa9a3fd7a38f902dc749d4835270ab21 (diff)
use OsPath instead of FilePath in easy cases
this is still far from being supported by most libraries, but does make it possible to remove some uses of String (though most times, there is a conversion back to String later). Note that using the default.nix now only works on nixpkgs-unstable for a bit; using the newer filepath package on stable leads to broken other packages.
Diffstat (limited to '')
-rw-r--r--default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index d6ce56c..4b317b9 100644
--- a/default.nix
+++ b/default.nix
@@ -7,7 +7,7 @@ let
f = { mkDerivation, aeson, base, blaze-html, blaze-markup
, bytestring, cassava, conduit, conferer, conferer-aeson
, conferer-warp, conferer-yaml, containers, data-default-class
- , directory, either, exceptions, extra, fmt, hoauth2, http-api-data
+ , directory, either, exceptions, extra, filepath, fmt, hoauth2, http-api-data
, http-media, insert-ordered-containers, lens, lib, monad-logger
, mtl, path-pieces, persistent, persistent-postgresql
, prometheus-client, prometheus-metrics-ghc, proto-lens
@@ -27,7 +27,7 @@ let
isExecutable = true;
libraryHaskellDepends = [
aeson base blaze-html blaze-markup bytestring cassava conduit
- conferer conferer-warp containers either exceptions extra fmt
+ conferer conferer-warp containers either exceptions extra fmt filepath
hoauth2 http-api-data http-media insert-ordered-containers lens
monad-logger mtl path-pieces persistent persistent-postgresql
prometheus-client prometheus-metrics-ghc proto-lens
@@ -63,6 +63,7 @@ let
# (currently kept as a dummy)
hpkgs = haskellPackages.override {
overrides = self: super: with pkgs.haskell.lib.compose; {
+ # filepath = self.filepath_1_4_100_4;
# conferer-warp = markUnbroken super.conferer-warp;
};
};