summaryrefslogtreecommitdiff
path: root/server/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'server/shell.nix')
-rw-r--r--server/shell.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/server/shell.nix b/server/shell.nix
new file mode 100644
index 0000000..1af9bbb
--- /dev/null
+++ b/server/shell.nix
@@ -0,0 +1,14 @@
+let
+ moz_overlay = import (builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz);
+ nixpkgs = import <nixpkgs> { overlays = [ moz_overlay ]; };
+in
+ with nixpkgs;
+ stdenv.mkDerivation {
+ name = "moz_overlay_shell";
+ buildInputs = [
+ #nixpkgs.latest.rustChannels.nightly.rust
+ nixpkgs.latest.rustChannels.stable.rust
+ openssl pkg-config
+ rls cargo
+ ];
+ }