summaryrefslogtreecommitdiff
path: root/utils/Cargo.toml
diff options
context:
space:
mode:
authorstuebinm2021-04-05 00:57:16 +0200
committerstuebinm2021-04-05 00:57:16 +0200
commit311c66047f7187feaf4ed33eea0cc64baf933874 (patch)
treee938325f7f7268c822f0580a56f1193da97565f7 /utils/Cargo.toml
parent0f8b78c0b7e2aca94a14b36af020d0f7d8301cc5 (diff)
add utility program
This can be used to write configs in dhall (instead of plain json), combined with some input validation and (optionally) automatic encryption via the age rust crate.
Diffstat (limited to '')
-rw-r--r--utils/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/utils/Cargo.toml b/utils/Cargo.toml
new file mode 100644
index 0000000..566d604
--- /dev/null
+++ b/utils/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "rust"
+version = "0.1.0"
+authors = ["stuebinm <stuebinm@disroot.org>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+serde = { version = "1.0", features = [ "derive" ] }
+serde_dhall = "0.10.0"
+serde_json = "1.0.64"
+age = "0.5.1"
+structopt = "0.3.21"
+secrecy = "0.7.0"