summaryrefslogtreecommitdiff
path: root/rusty-haskell/rust/Cargo.toml
diff options
context:
space:
mode:
authorstuebinm2021-04-11 03:37:32 +0200
committerstuebinm2021-04-11 03:37:32 +0200
commitfa49e0bf71ccd4bc98df0fa83546250c1b849e2e (patch)
treef84c1ff8000fe87fae6b7c703e6b7871101a5094 /rusty-haskell/rust/Cargo.toml
parentf7605dfefa304b1a7b20a474ce168cd5b9849533 (diff)
simple ffi with rust and haskell
so far, only calling rust from haskell, not the other way round.
Diffstat (limited to '')
-rw-r--r--rusty-haskell/rust/Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/rusty-haskell/rust/Cargo.toml b/rusty-haskell/rust/Cargo.toml
new file mode 100644
index 0000000..0bef17d
--- /dev/null
+++ b/rusty-haskell/rust/Cargo.toml
@@ -0,0 +1,13 @@
+[package]
+name = "rustlib"
+version = "0.1.0"
+authors = ["stuebinm <stuebinm@disroot.org>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[lib]
+name = "rustlib"
+crate-type = ["staticlib"]
+
+[dependencies]