aboutsummaryrefslogtreecommitdiff
path: root/picarones-hs/build.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--picarones-hs/build.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/picarones-hs/build.nix b/picarones-hs/build.nix
new file mode 100644
index 0000000..c61d763
--- /dev/null
+++ b/picarones-hs/build.nix
@@ -0,0 +1,15 @@
+{ mkDerivation, aeson, base, bytestring, stdenv, text
+, unordered-containers, websockets
+}:
+mkDerivation {
+ pname = "picarones-hs";
+ version = "0.1.0.0";
+ src = ./.;
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson base bytestring text unordered-containers websockets
+ ];
+ license = "unknown";
+ hydraPlatforms = stdenv.lib.platforms.none;
+}