summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..7c3c8d6
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "nixq"
+version = "0.1.0"
+edition = "2021"
+authors = [ "stuebinm <stuebinm@disroot.org>" ]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+rnix = "0.11"
+anyhow = "1.0.57"
+regex = "1.6"
+threadpool = "1.8.1"
+rowan = "0.15.15"
+serde_json = "1.0.114"
+serde = { version = "1.0.197", features = ["derive"] }
+itertools = "0.12.1"