summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/overlay.nix')
-rw-r--r--pkgs/overlay.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 3a37b8f..c7e929e 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -50,6 +50,39 @@ in
cargoLock.lockFile = "${src}/Cargo.lock";
};
+ mergiraf = self.rustPlatform.buildRustPackage rec {
+ pname = "mergiraf";
+ version = "git";
+ src = self.fetchgit {
+ url = "https://codeberg.org/mergiraf/mergiraf";
+ rev = "v0.2.0";
+ hash = "sha256-egtX2daCbPXi5rX2OxbEZA/VI9R4HMj5LRKbUEBFo+E=";
+ };
+ # TODO: probably unnecessary once we are on nixpkgs 24.11; earlier version
+ # hardcode --frozen here, but cargo wants --offline.
+ # the postBuild hook is necessary to set up things for the install hook
+ buildPhase = ''
+ cargo build -j $NIX_BUILD_CORES \
+ --target x86_64-unknown-linux-gnu \
+ --release \
+ --offline
+
+ runHook postBuild
+ '';
+ # no idea why this didn't work with either test or build inputs ..
+ preCheck = ''
+ export PATH=$PATH:${self.gitMinimal}/bin
+ '';
+ cargoLock = {
+ lockFile = "${src}/Cargo.lock";
+ outputHashes = {
+ "tree-sitter-go-0.23.1" = "sha256-elPqkvVYs0vADOuN/umDteWP5hqcXhQAoSkqYDtTxaU=";
+ "tree-sitter-xml-0.7.0" = "sha256-RTWvOUAs3Uql9DKsP1jf9FZZHaZORE40GXd+6g6RQZw=";
+ "tree-sitter-yaml-0.6.1" = "sha256-gS+SjOnGl/86U9VV/y1ca7naYIe7DAOvOv++jCRLTKo=";
+ };
+ };
+ };
+
rustex = rustPlatform.buildRustPackage rec {
pname = "rustex";
version = "git";