summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pkgs/overlay.nix62
1 files changed, 60 insertions, 2 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 75e8cfc..bfc0175 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -14,7 +14,65 @@ self: super:
});
typst = self.callPackage ./typst.nix {
- craneLib = (inputs.crane.mkLib self).overrideToolchain
- self.rust-bin.stable.latest.default;
+ rust-bin =
+ self.rust-bin;
};
+
+ almanac = self.rustPlatform.buildRustPackage rec {
+ pname = "almanac";
+ version = "git";
+ src = inputs.almanac.outPath;
+ cargoLock.lockFile = "${src}/Cargo.lock";
+ };
+
+ kijetesantakaluotokieni = self.rustPlatform.buildRustPackage rec {
+ pname = "kijetesantakaluotokieni";
+ version = "git";
+ src = self.fetchgit {
+ url = "https://git.2ki.xyz/spiders/kijetesantakaluotokieni";
+ rev = "7d9ea828f42ffd9fb6826ea4cbf7677b08222064";
+ sha256 = "sha256-PEp+K5mRNUR6yWLrpGpiX8qvaPQIibA17NQwXUiC2lk=";
+ };
+ cargoLock.lockFile = "${src}/Cargo.lock";
+ };
+
+ showrt = self.rustPlatform.buildRustPackage rec {
+ pname = "showrt";
+ version = "git";
+ src = inputs.showrt;
+ nativeBuildInputs = [ self.protobuf ];
+ cargoLock.lockFile = "${src}/Cargo.lock";
+ };
+
+ isabelle-utils = self.rustPlatform.buildRustPackage rec {
+ pname = "isabelle-utils";
+ version = "git";
+ src = inputs.isabelle-utils;
+ cargoLock.lockFile = "${src}/Cargo.lock";
+ checkPhase = "
+ echo skipping tests
+ ";
+ };
+
+ isabat = import "${inputs.isabelle-utils}/isabat.nix" {
+ pkgs = self;
+ isabelle-rust-utils = self.isabelle-utils;
+ };
+
+ emacs29 = self.callPackage
+ (import "${inputs.nixpkgs.outPath}/pkgs/applications/editors/emacs/generic.nix" {
+ version = "29";
+ sha256 = "sha256-AI4eNgzRLnM1s4hQa0YWJxZR3WZoIuKy7BYosT06K1c=";
+ }) {
+ inherit (self.darwin.apple_sdk.frameworks) AppKit Carbon Cocoa IOKit OSAKit Quartz
+ QuartzCore WebKit ImageCaptureCore GSS ImageIO;
+ gconf = null;
+ alsa-lib = null;
+ gpm = null;
+ libXaw = self.xorg.libXaw;
+ inherit (self.darwin) sigtool;
+ withPgtk = true;
+ withX = false;
+ };
+
}