summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pkgs/overlay.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index b54a774..2d561ff 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -243,6 +243,30 @@ in
};
});
+ git-who = self.buildGoModule rec {
+ pname = "git-who";
+ version = "0.7";
+
+ src = (self.fetchFromGitHub {
+ owner = "sinclairtarget";
+ repo = "git-who";
+ rev = "v${version}";
+ hash = "sha256-Ujtwb4DTK7dUcyHvaF52a/YF3YO6WyszUIoxrEKE9jo=";
+ # submodules contain test data and have ssh urls, hence this absurdity
+ fetchSubmodules = true;
+ leaveDotGit = true;
+ }).overrideAttrs {
+ GIT_CONFIG_COUNT = 1;
+ GIT_CONFIG_KEY_0 = "url.https://github.com/.insteadOf";
+ GIT_CONFIG_VALUE_0 = "git@github.com:";
+ };
+
+ vendorHash = "sha256-e2P7szjtAn4EFTy+eGi/9cYf/Raw/7O+PbYEOD8i3Hs=";
+
+ nativeCheckInputs = [ self.gitMinimal ];
+ };
+
+
hikari = self.callPackage ./hikari.nix { wlroots = self.wlroots_0_15; };
wlroots_0_15 = self.callPackage ./wlroots_0_15.nix {};