summaryrefslogtreecommitdiff
path: root/pkgs/mollysocket.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/mollysocket.nix')
-rw-r--r--pkgs/mollysocket.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/mollysocket.nix b/pkgs/mollysocket.nix
new file mode 100644
index 0000000..8ac434d
--- /dev/null
+++ b/pkgs/mollysocket.nix
@@ -0,0 +1,38 @@
+{ lib, rustPlatform, fetchFromGitHub, pkg-config, openssl, sqlite, ... }:
+
+rustPlatform.buildRustPackage rec {
+ pname = "mollysocket";
+ version = "1.2.0";
+
+ src = fetchFromGitHub {
+ owner = "mollyim";
+ repo = "mollysocket";
+ rev = "${version}";
+ hash = "sha256-9yXC64i5NeSjsLnjgNtA+qkhE7i+Ku1Cu8B9xDajD9Y=";
+ };
+
+ cargoHash = "sha256-vqi18y1Z9Fo1P6ihdN1LCK6Trr7fcfzCsQfPNt0MYNk=";
+
+ nativeBuildInputs = [ pkg-config ];
+
+ buildInputs = [ openssl sqlite ];
+
+ checkFlags = [
+ # These tests try to contact DNS
+ "--skip=config::tests::check_wildcard_endpoint"
+ "--skip=utils::post_allowed::tests::test_allowed"
+ "--skip=utils::post_allowed::tests::test_not_allowed"
+ "--skip=utils::post_allowed::tests::test_post"
+ "--skip=ws::tls::tests::connect_untrusted_server"
+ "--skip=ws::tls::tests::connect_trusted_server"
+ ];
+
+ meta = {
+ description =
+ "MollySocket allows getting Signal notifications via UnifiedPush.";
+ homepage = "https://github.com/mollyim/mollysocket";
+ license = lib.licenses.agpl3Plus;
+ maintainers = with lib.maintainers; [ networkexception ];
+ mainProgram = "mollysocket";
+ };
+}