summaryrefslogtreecommitdiff
path: root/pkgs/bookwyrm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/bookwyrm.nix')
-rw-r--r--pkgs/bookwyrm.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/bookwyrm.nix b/pkgs/bookwyrm.nix
index 309e90b..0c9cb70 100644
--- a/pkgs/bookwyrm.nix
+++ b/pkgs/bookwyrm.nix
@@ -11,7 +11,6 @@ let
settingsWithDefaults = {
DOMAIN = "localhost";
DEBUG = false;
- SECRET_KEY = "fnord";
USE_HTTPS = false;
EMAIL = "your@email.here";
PGPORT = 5432;
@@ -95,6 +94,9 @@ let
postBuild = ''
ln -s ${envfile} .env
+ # needed for the python settings.py file to not fail, but not
+ # used during the commands executed below, so this is safe
+ export SECRET_KEY=fnord
substituteInPlace contrib/systemd/* \
--replace /opt/bookwyrm/venv/bin/gunicorn ${lib.getExe python.pkgs.gunicorn} \
@@ -104,7 +106,7 @@ let
sed -i /BindPath/d contrib/systemd/*
python manage.py compile_themes
- python manage.py collectstatic --no-input --ignore=*.scss
+ python manage.py collectstatic --no-input
'';
postInstall = ''