summaryrefslogtreecommitdiff
path: root/pkgs/bookwyrm.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pkgs/bookwyrm.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/bookwyrm.nix b/pkgs/bookwyrm.nix
index 0c9cb70..7a5daec 100644
--- a/pkgs/bookwyrm.nix
+++ b/pkgs/bookwyrm.nix
@@ -119,7 +119,11 @@ let
pythonPath = python.pkgs.makePythonPath propagatedBuildInputs;
gunicorn = python.pkgs.gunicorn;
celery = python.pkgs.celery;
- manage = writeShellScriptBin "bookwyrm-manage.py" ''
+ manage = environmentFile: writeShellScriptBin "bookwyrm-manage.py" ''
+ set -a
+ ${if environmentFile != null
+ then "source ${environmentFile}"
+ else ""}
export PYTHONPATH=${passthru.pythonPath}
cd ${bookwyrm.outPath}
exec ${bookwyrm.outPath}/manage.py "$@"