summaryrefslogtreecommitdiff
path: root/ilex/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ilex/configuration.nix16
1 files changed, 4 insertions, 12 deletions
diff --git a/ilex/configuration.nix b/ilex/configuration.nix
index e309c41..e87af9a 100644
--- a/ilex/configuration.nix
+++ b/ilex/configuration.nix
@@ -43,24 +43,16 @@
ensureDatabases = [ "tracktrain" "glitchtrip" "crstracker" "travelynx" ];
ensureUsers = [ {
name = "tracktrain";
- ensurePermissions = {
- "DATABASE tracktrain" = "ALL PRIVILEGES";
- };
+ ensureDBOwnership = true;
} {
name = "travelynx";
- ensurePermissions = {
- "DATABASE travelynx" = "ALL PRIVILEGES";
- };
+ ensureDBOwnership = true;
} {
name = "glitchtrip";
- ensurePermissions = {
- "DATABASE glitchtrip" = "ALL PRIVILEGES";
- };
+ ensureDBOwnership = true;
} {
name = "crstracker";
- ensurePermissions = {
- "DATABASE crstracker" = "ALL PRIVILEGES";
- };
+ ensureDBOwnership = true;
} ];
authentication = ''
local all all trust