summaryrefslogtreecommitdiff
path: root/hosts/flora/services/grafana.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/flora/services/grafana.nix')
-rw-r--r--hosts/flora/services/grafana.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/hosts/flora/services/grafana.nix b/hosts/flora/services/grafana.nix
deleted file mode 100644
index 15fd254..0000000
--- a/hosts/flora/services/grafana.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ config, pkgs, ... }:
-
-{
- services.prometheus = {
- enable = true;
- port = 9001;
- scrapeConfigs = [ {
- job_name = "lmucast-docker";
- static_configs = [ {
- targets = [ "cast.itunes.uni-muenchen.de:9101" ];
- } ];
- } ];
- };
-
- services.grafana = {
- enable = true;
- port = 5000;
- addr = "[::]";
- rootUrl = "https://scrape.stuebinm.eu/";
- auth.anonymous.enable = true;
- provision = {
- enable = true;
- datasources = [ {
- name = "lmucast";
- type = "prometheus";
- url = "http://localhost:9001";
- } ];
- };
- };
-
- services.nginx.virtualHosts."scrape.stuebinm.eu" = {
- locations."/" = {
- proxyPass = "http://localhost:5000";
- proxyWebsockets = true;
- };
- enableACME = true;
- forceSSL = true;
- };
-
- networking.firewall.allowedTCPPorts = [ 80 443 ];
-}