summaryrefslogtreecommitdiff
path: root/hosts/chaski/services/woitb.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/chaski/services/woitb.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/hosts/chaski/services/woitb.nix b/hosts/chaski/services/woitb.nix
new file mode 100644
index 0000000..303ec0f
--- /dev/null
+++ b/hosts/chaski/services/woitb.nix
@@ -0,0 +1,32 @@
+{ config, lib, pkgs, ... }:
+
+let
+ #sources = ../../nix/sources.nix;
+ sources = /home/stuebinm/Dokumente/utils/playground/ilztal/server;
+in
+{
+ systemd.services.woitb = {
+ enable = true;
+ description = "wo ist die ilztalbahn?";
+ wantedBy = [ "multi-user.target" ];
+ serviceConfig.type = "simple";
+ script = "${import sources}/bin/woitb";
+ };
+
+ services.nginx.virtualHosts."ilztal.live" = {
+ enableACME = true;
+ forceSSL = true;
+ locations."/".root = pkgs.copyPathToStore
+ /home/stuebinm/Dokumente/utils/playground/ilztal/site;
+
+ locations."/upnext".proxyPass = "http://localhost:8000";
+ locations."/geoloc".proxyPass = "http://localhost:8000";
+ };
+
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
+
+ services.nginx.appendHttpConfig = ''
+ access_log off;
+ add_header Permissions-Policy "interest-cohort=()";
+ '';
+}