summaryrefslogtreecommitdiff
path: root/home/packages.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/packages.nix37
1 files changed, 11 insertions, 26 deletions
diff --git a/home/packages.nix b/home/packages.nix
index 16e8e3c..0250184 100644
--- a/home/packages.nix
+++ b/home/packages.nix
@@ -10,12 +10,12 @@ in
emacs-all-the-icons-fonts nerdfonts
# internet apps & clients
- firefox keepassxc mumble lynx thunderbird offpunk
- openconnect matterhorn tdesktop monolith magic-wormhole-rs
+ firefox keepassxc mumble lynx offpunk
+ openconnect tdesktop monolith magic-wormhole-rs
dino
# graphics & audio
- audacity blender darktable kdenlive moc ffmpeg-full
- gimp-with-plugins inkscape krita meshlab pavucontrol moc
+ audacity blender darktable ffmpeg-full
+ gimp-with-plugins inkscape krita pavucontrol
gst_all_1.gstreamer vimiv-qt
# LaTeX & documents
xournal pandoc zathura pdfpc
@@ -27,12 +27,12 @@ in
# general cli utils
almanac libnotify grim slurp (zbar.override { enableVideo = false; withXorg = false; })
wl-clipboard showrt
- kijetesantakaluotokieni mpc_cli duf dufs progress hledger
+ kijetesantakaluotokieni mpc_cli dufs progress hledger
wineWowPackages.full sops xdg-utils exiftool
mercurial darcs git-annex-remote-remarkable2
rlwrap
# graphical utils
- kitty baobab
+ kitty
# gnss things
gpsd # galmon-full
# transport things
@@ -48,37 +48,22 @@ in
racket dhall dune_2 ocamlPackages.utop ocamlPackages.ocp-indent
ocamlPackages.merlin ocaml gauche
(agda.withPackages (p: [ p.standard-library p.cubical ]))
- (twelf.overrideAttrs (old: {
- src = fetchFromGitHub {
- owner = "k4rtik";
- repo = "twelf";
- rev = "c1bec0d0b9fa506e36bb364b1765191b159e6c4c";
- hash = "sha256-sh/yMlCvMMq6GBqAKO+V0Bcyp38zB7I/3H8a0fxqOos=";
- };
- }))
+
# html, js & co
jq ijq html-tidy nodePackages.stylelint nodePackages.js-beautify zola
libxml2 fq htmlq
- # purescript
- #spago purescript # nodePackages.purescript-language-server nodejs
# rust
- #cargo rustc
- rust-bin.stable.latest.minimal
- rust-analyzer rustfmt
+ rust-bin.stable.latest.minimal rust-analyzer rustfmt
# go
go gopls godef gore gotests gomodifytags
# C/C++
clang clang-tools rtags irony-server
# others
- julia python39 inweb
+ python39 inweb
# nix things
- niv
- #haskellPackages.nix-serve-ng
- nix-doc nix-output-monitor
- direnv
+ niv npins nix-output-monitor direnv
# isabelle
- (isabelle.mkEnv "isabelle-env" "fish")
- isabat
+ (isabelle.mkEnv "isabelle-env" "fish") isabat
(import inputs.traveltext { inherit pkgs; })
];