summaryrefslogtreecommitdiff
path: root/home/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/home.nix')
-rw-r--r--home/home.nix137
1 files changed, 39 insertions, 98 deletions
diff --git a/home/home.nix b/home/home.nix
index f61e7d8..1846e12 100644
--- a/home/home.nix
+++ b/home/home.nix
@@ -7,10 +7,9 @@
imports = [
./packages.nix
./unstable.nix
+ ./home-minimal.nix
];
- home.keyboard.options = [ "caps:escape" ];
-
programs.msmtp.enable = true;
programs.mbsync.enable = true;
programs.mu.enable = true;
@@ -34,35 +33,13 @@
};
programs.bash = {
- enable = true;
- historyControl = [ "ignoredups" "ignorespace" ];
- historyFileSize = 10000;
-
- # set shell prompt & tty for the gnu pinentry (otherwise gnupg will crash)
- initExtra = ''
- export GPG_TTY=`tty`
- # this shouldn't be necessary, but apparently nix is broken ...
- NIX_PATH=$HOME/.nix-defexpr/channels''${NIX_PATH:+:}$NIX_PATH
- PS1='\[\033[1;36m\] >>> [\j|\u@\w]\$: \[\033[00m\]'
- '';
-
shellAliases = {
"lrz-vpn" = "sudo openconnect https://asa-cluster.lrz.de -g AnyConnect";
- ll = "ls -slF";
news = "newsboat";
pj = "pijul";
};
};
- programs.starship = {
- enable = true;
- enableBashIntegration = true;
- enableFishIntegration = true;
- settings = {
- directory.truncation_length = 10;
- };
- };
-
programs.nushell = {
enable = true;
settings = {
@@ -76,23 +53,12 @@
};
programs.fish = {
- enable = true;
shellAliases = {
"lrz-vpn" = "sudo openconnect https://asa-cluster.lrz.de";
news = "newsboat";
pj = "pijul";
- nix-shell = "nix-shell --command fish";
- le = "exa";
- ll = "exa -lh --icons";
- llt = "exa -lh --tree --icons";
- lt = "exa --tree --icons";
agenda = "almanac month ~/.cache/feedsync/*";
};
- functions = {
- fish_greeting = {
- body = "";
- };
- };
};
programs.kitty = {
@@ -101,6 +67,44 @@
background_opacity 0.8
'';
};
+
+ programs.neovim = {
+ enable = true;
+ viAlias = true;
+ plugins = with pkgs; [
+ (vimPlugins.nvim-treesitter.withPlugins
+ (plugins: [ tree-sitter-grammars.tree-sitter-nix ]))
+ ];
+ generatedConfigViml = ''
+ lua <<EOF
+ require'nvim-treesitter.configs'.setup {
+ -- One of "all", "maintained" (parsers with maintainers), or a list of languages
+ ensure_installed = "all",
+
+ -- Install languages synchronously (only applied to `ensure_installed`)
+ sync_install = false,
+
+ -- List of parsers to ignore installing
+ ignore_install = { "javascript" },
+
+ highlight = {
+ -- `false` will disable the whole extension
+ enable = true,
+
+ -- list of language that will be disabled
+ -- disable = { "c", "rust" },
+
+ -- Setting this to true will run `:h syntax` and tree-sitter at the same time.
+ -- Set this to `true` if you depend on 'syntax' being enabled (like for indentation).
+ -- Using this option may slow down your editor, and you may see some duplicate highlights.
+ -- Instead of true it can also be a list of languages
+ additional_vim_regex_highlighting = false,
+ },
+ }
+ EOF
+ '';
+ };
+
systemd.user.services.syncical = let
feeds = (import inputs.feeds).ical; in {
Unit.Description = "syncs ical feeds for almanac agenda";
@@ -150,12 +154,6 @@
};
- programs.bat = {
- enable = true;
- config.wrap = "never";
- };
-
-
programs.obs-studio = {
enable = true;
plugins = let
@@ -166,36 +164,6 @@
];
};
- programs.git = {
- enable = true;
- package = pkgs.gitAndTools.gitFull;
- userEmail = "stuebinm@disroot.org";
- userName = "stuebinm";
-
- signing = {
- # signByDefault = true;
- key = "0x8FBE8AAD32FA12B7";
- };
-
- extraConfig = {
- log.showSignature = true;
- init.defaultBranch = "main";
- };
-
- delta = {
- enable = true;
- options = {
- decorations = {
- commit-decoration-style = "bold yellow";
- file-decoration-style = "bold blue";
- file-style = "bold yellow";
- };
- features = "decorations line-numbers navigate";
- whitespace-error-style = "22 reverse";
- };
- };
- };
-
programs.gpg = {
enable = true;
settings = {
@@ -209,33 +177,6 @@
maxCacheTtl = 1800;
};
-
- programs.htop = {
- package = pkgs.htop-vim;
- enable = true;
- settings = {
- fields = "0 48 17 18 38 46 47 49 1";
- sort_key = 46;
- sort_direction = -1;
- hide_kernel_threads = 1;
- hide_userland_threads = 0;
- shadow_other_users = 1;
- show_program_path = 0;
- highlight_base_name = 1;
- find_comm_in_cmdline = 1;
- header_margin = 1;
- show_cpu_usage = 1;
- color_scheme = 5;
- enable_mouse = 1;
- delay = 15;
- header_layout = "two_67_33";
- column_meters_0 = "AllCPUs Memory Swap";
- column_meter_modes_0 = "1 1 1";
- column_meters_1 = "Tasks LoadAverage Uptime NetworkIO";
- column_meter_modes_1 = "2 2 2 2";
- };
- };
-
programs.ssh = {
forwardAgent = true;
enable = true;