summaryrefslogtreecommitdiff
path: root/flora/services/trainspotter.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/trainspotter.nix')
-rw-r--r--flora/services/trainspotter.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/flora/services/trainspotter.nix b/flora/services/trainspotter.nix
new file mode 100644
index 0000000..5b81f7e
--- /dev/null
+++ b/flora/services/trainspotter.nix
@@ -0,0 +1,17 @@
+{ config, lib, pkgs, ... }:
+
+{
+ systemd.services.trainspotter = {
+ enable = true;
+ description = "script watching the ilztalbahn gtfs for changes";
+ wantedBy = [ "multi-user.target" ];
+ after = [ "network.target" ];
+ serviceConfig.Type = "simple";
+ path = with pkgs; [ curl libzip mailutils ];
+ script = ''
+ ${pkgs.gauche}/bin/gosh ${pkgs.copyPathToStore ./trainspotter.scm}
+ '';
+ startAt = "daily";
+ };
+
+}