summaryrefslogtreecommitdiff
path: root/flora/services/monit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/monit.nix')
-rw-r--r--flora/services/monit.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/flora/services/monit.nix b/flora/services/monit.nix
new file mode 100644
index 0000000..c8f7b3f
--- /dev/null
+++ b/flora/services/monit.nix
@@ -0,0 +1,32 @@
+{ config, lib, pkgs, ... }:
+
+{
+ # includes mail address, which includes ntfy token
+ sops.secrets."monit/mail" = {};
+
+ services.monit = {
+ enable = true;
+
+ config = ''
+ include /run/secrets/monit/mail
+
+ set daemon 120 with start delay 60
+ set mailserver
+ localhost
+ port 2525
+
+ set httpd port 2812 and use address localhost
+ allow localhost
+ allow admin:obwjoawijerfoijsiwfj29jf2f2jd
+
+ check filesystem root with path /
+ if space usage > 80% then alert
+ if inode usage > 80% then alert
+
+ check host stuebinm.eu with address stuebinm.eu
+ if failed
+ port 443 protocol https
+ then alert
+ '';
+ };
+}