summaryrefslogtreecommitdiff
path: root/flora/services/monit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/monit.nix')
-rw-r--r--flora/services/monit.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/flora/services/monit.nix b/flora/services/monit.nix
index e9544e1..6c11522 100644
--- a/flora/services/monit.nix
+++ b/flora/services/monit.nix
@@ -75,4 +75,13 @@
}
'';
};
+
+ systemd.services.monit_prometheus = {
+ enable = true;
+ serviceConfig = {
+ ExecStart = "${pkgs.gauche}/bin/gosh ${pkgs.copyPathToStore ../../pkgs/scripts/monit-prometheus.scm} -i http://localhost:2812 -o /tmp/dings";
+ };
+ path = [ pkgs.curl ];
+ startAt = "*-*-* *:*:00";
+ };
}